Forum

Forum feed

» zum Forum | » aktuelle Diskussionen

Kommentare

Forum feed

[gelöst] ADODB Extension - bytecache  Unten

  • Eine Frage an die Profis:

    Ist die ADODB extension noch interessant für Zikula 1.2.9 unter XAMPP auf Windows ?
    Ich habe dort die adobe.dll in den ext-Ordner gelegt und die Eintragung in der php.ini vorgenommen - Die Systeminformationen im Adminbereich sagen mir trotzdem, dass ADODB nicht läuft.

    Kann das an php 5.4.4 liegen?

    -.-.-.-.-.-.-.-.-.-.-.-
    Frank
  • Der Aufwand lohnt meines Erachtens nicht mehr wirklich: durch einen Bytecache wie etwa APC hat man in Sachen Geschwindigkeit vermutlich mehr gewonnen. Ab Version 1.3 ist ADODB ohnehin nicht mehr im Core vorhanden. Doctrine und Doctrine 2 können indes auch beide mit APC arbeiten.

    Ich bin mir im Übrigen nicht sicher, ob 1.2.9 gut mit PHP 5.4 harmoniert. Hier würde ich entweder auf PHP 5.3 setzen oder auf Zikula 1.3.3 umsteigen.

  • Danke für die Info, bringt mich gut weiter.

    Quote

    Ich bin mir im Übrigen nicht sicher, ob 1.2.9 gut mit PHP 5.4 harmoniert. Hier würde ich entweder auf PHP 5.3 setzen oder auf Zikula 1.3.3 umsteigen.


    Das hatte ich schon so "gefühlt" beim Testen, werden den Server wieder auf php 5.3 umstellen, obwohl bisher keine Fehlermeldungen auftauchten.



    Bearbeitet von FRW am 13. Jul 2012 - 09:33.

    -.-.-.-.-.-.-.-.-.-.-.-
    Frank
  • Habe mich mal etwas durch diverse (Wiki-)Literatur gewühlt und mich jetzt für die folgende Kombination entschieden:

    Zikula 1.29 auf XAMPP 1.77 mit php 5.3.8 und Mysql 5.5.16 mit XCache 2.0.0

    Unser Intranet fühlte sich noch nie so performant an.... icon_wink

    -.-.-.-.-.-.-.-.-.-.-.-
    Frank
  • Leider lässt mich content jetzt keine Inhalte mehr bearbeiten.....

    Fehler im apache-log:

    Quote

    Call to a member function dataBound() on a non-object in C:\XAMPP\htdocs\includes\pnForm.php on line 258


    -.-.-.-.-.-.-.-.-.-.-.-
    Frank
  • Versuche mal XCache auszuschalten. Wenn es dann geht, probiere APC statt XCache.

  • Danke, habe ich gerade gemacht, auch eine frische XAMPP-Installation ohne Cache bringt leider den gleichen Fehler zu databound()

    xampplite mit php5.3.8 -> läuft ohne Fehler
    XAMPP mit php5.3.8 -> databound Fehler



    Bearbeitet von FRW am 13. Jul 2012 - 12:44.

    -.-.-.-.-.-.-.-.-.-.-.-
    Frank
  • Habe mir jetzt mal apc installiert, läuft auch prima. leider immer noch den databound() Fehler.
    @guite:
    Hats Du für Zikula Einstellungsempfehlungen für apc (Server hat derzeit 4GB RAM)?

    -.-.-.-.-.-.-.-.-.-.-.-
    Frank
  • So, nach einer intensiven WinMerge-Studie hat sich der Übeltäter in Form einer fehlerhaft kopierten pnForm.php eröffnet.

    -.-.-.-.-.-.-.-.-.-.-.-
    Frank
  • 0 Benutzer

Diese Angaben basieren auf den Useraktivitäten der letzten 30 Minuten.