Kommentare

Forum feed

[gelöst]Upgradefehler im extensions Module  Unten

  • Beim Versuch upgrades im Extensions Modul aufzurufen erhalte ich folgenden Fehler.


    Could not load the 'extensions' module at 'upgradeall'.
    SQLSTATE[23000]: Integrity constraint violation: 1062 Duplicate entry 'news.ui_hooks.articles.display_view' for key 'myindex'

    Vielen Dank für Lösungsvorschläge.

    Das ist nicht meine Signatur, sie verfolgt nur meine Threads...
  • Das News-Modul versucht eine Hook-Area anzulegen, die aber bereits existiert.
    Ein Workaround wäre es diesen Teil im Upgrade auszukommentieren.

    Hattest Du vorher eine Entwicklungsversion am Laufen?
    Wenn nein, erstelle bitte ein Ticket für das News-Projekt.

  • Vielen Dank für Deine Hilfe. Ich hatte zwar keine Entwicklungsversion laufen, hatte es aber unbewusst versucht. Habe mir bei Github das Modul herunter geladen. GitHub ist für mich leider noch sehr neu und unübersichtlich. Beim Newsupgrade stand dann auch Version 3.0.1 wenn ich mich recht erinnere. Das Upgrade lief dann schief, mit besagter Fehlermeldung. Habe mir die installer.php angesehen und bin mir unsicher ob ich da überhaupt richtig bin und welchen Abschnitt ich ggf. wie auskommentieren müsste.
    Nochmals vielen Dank.

    Conga

    Das ist nicht meine Signatur, sie verfolgt nur meine Threads...
  • Nutzt Du bereits Hooks im News-Modul? Wenn nicht, könntest Du einfach die ganzen News-Einträge aus den Datenbanktabellen hook* entfernen.

  • Ich hatte zwar EZComments im Einsatz, aber ob dies ein echter Hook ist, ist mir bis heute nicht so ganz klar. Wie dem auch sei, das leeren der in der Fehlermeldung hingewiesenen Tabelle hat den Fehler beseitigt. Vielen Dank und ein schönes WE.

    Conga



    Bearbeitet von Conga am 18. Aug 2012 - 20:36.

    Das ist nicht meine Signatur, sie verfolgt nur meine Threads...
  • 0 Benutzer

Diese Angaben basieren auf den Useraktivitäten der letzten 30 Minuten.