Forum

Forum feed

» zum Forum | » aktuelle Diskussionen

Zikula Nachrichten

RSS Feed

Ernster Core-1.4.2 Upgrade Bug entdeckt

Bedauerlicherweise wurde ein ernstzunehmender Fehler im Upgrade-Prozess des 1.4.2 Core entdeckt. Auf Grund dieses Bugs können wir aktuell keine Aktualisierungen auf 1.4.2 von vorherigen Versionen von Zikula empfehlen.

Eine direkte Neuinstallation vom Core 1.4.2 arbeitet korrekt und ist nicht von diesem Problem betroffen.

Der Bug wurde bereits im 1.4.3 Core entdeckt und wir hoffen, dass diese Version innerhalb dieses Monats veröffentlicht wird.

Der Bug löscht beim Upgrade die Inhaltsdaten von der Block-Tabelle, was die Darstellung aller Blocks ungültig macht und verschiedene andere Probleme verursacht. Es gibt aktuell keine Workaround außer das manuelle Löschen aller Blöcke (in den Tabellen blocks und blocks_placements) und das anschließende Neuerstellen.

Wir möchten uns für diese Umstände vielmals entschuldigen.



 

Themen


Kommentare

  • Geschrieben am
  • 16. Aug 2016 - 13:02
Roadmap

Wie sieht es denn mit einer neuen Roadmap für 2.0 aus? Da der Support für php 5 dieses Jahr endet und im Forum zu erfahren war, das erst Zikula 2.0 mit php 7 funktionieren wird, wäre es doch langsam an der Zeit das auf den Weg zu bringen!?

  • Geschrieben am
  • 16. Aug 2016 - 20:53
Gemach gemach

Ich muss sagen, dass ich Debatten über 2.0 zum gegenwärtigen Zeitpunkt für, wie soll ich es ausdrücken, nicht hilfreich halte.

Es ist meines Erachtens Zeit, mal einen Stock hin zu stellen und Tempo heraus zu nehmen; und zwar im Hinblick auf technische Umstellungen.

Da kommt ja kein Mensch mehr hinterher; es sei denn er programmiert beruflich den ganzen Tag und hat Informatik studiert. Wer kümmert sich um die ganzen Module? Wer? icon_confused

  • Geschrieben am
  • 17. Aug 2016 - 11:04
Plan statt Debatte?

Ich dachte es gäbe einen Plan im Sinne einer Roadmap und wollte gar keine Debatte anstoßen icon_wink Gemach ist schlecht, wenn vorhersehbar ist das Zikula 1.4 dank PHP 7 in absehbarer Zeit nicht mehr laufen wird. http://support.zikula.de/module-CMS_Support_Forum-viewtopic-topic-31498-start-0.htm#pid149859 PHP 5.6 Support endet dieses Jahr / Security Updates bis Ende 2018. Es wird Interessierten dann wohl irgendwann die Zeit ablaufen wie soll das mit Gemach vereinbar sein?

Edit: Ich gaube Entwickler benötigen eine stabile Basis und keine Zwischenlösung(en)

  • Geschrieben am
  • 17. Aug 2016 - 13:25

php 5 will continue to be the dominant platform on most providers for a long time. There is no need to worry. The core developers are working as quickly as possible to move forward and toward Core-2.0. As always - it will be released when it's ready.

  • Geschrieben am
  • 14. Sep 2016 - 07:23

@ashnod: 1.4.x läuft mit php 7. Man muß lediglich das Error-Reporting so einstellen, dass "deprecated"-Fehler nicht angezeigt werden. Ansonsten sieht man eine Meldung wegen Smarty. Ich selbst entwickle am Core hier auf meinem lokalen Rechner seit einigen Monaten mit php 7.

Nur angemeldete Benutzer dürfen kommentieren. Registrierung oder Anmeldung.