Forum

Forum feed

» zum Forum | » aktuelle Diskussionen

Zikula Nachrichten

RSS Feed

Mark West mit zwei neuen Veröffentlichungen

Wie manche Leser vielleicht wissen, ist Mark West neben seiner Arbeit an PN .8 auch an einigen weiteren Projekten tätig, so dass er immer wieder mit kleinen Modulen, Hooks oder Themes aufwartet (wie z.B. das kubrick-Theme oder den Trackback-Hook).

Dieser Artikel stellt die beiden neuen Releases von Mark kurz vor. Zum einen ist der pnRender-Hook zu nennen, der es ermöglicht Smarty-Tags innerhalb von Modul-Inhalten zu benutzen. Zweitens wurde das Modul für Google Sitemaps freigegeben.


Der pnRender-Hook ist ein Transform-Hook (wie z.B. Autolinks oder pn_bbsmile), der es erlaubt Template-Logik von pnRender innerhalb von Modul-Inhalten zu benutzen. Das bedeutet, dass man z.B. in einem News-Artikel Plugins einbetten kann, sobald der Hook für ein Modul aktiviert wurde. Das Modul sollte unter allen PN-Versionen über .750 laufen, aber es wurde nur unter PostNuke .762 geschrieben und getestet.

Das Modul beinhaltet die Fähigkeit Template-Sicherheit zu aktivieren (was per Standard schon getan ist). Dies ist ein Modus der einschränkt, welche Smarty-Tags benutzt werden dürfen. So kann man unerwünschte Plugins aussperren.

Das in dem Artikel Google-Sitemaps…isch erstellen bereits vorgestellte Modul für Google Sitemaps ist nun erstmals veröffentlicht worden. Der Zweck hinter diesen Sitemaps besteht darin den Google-Bot durch eine XML-Datei mit der Struktur der Website zu füttern, so dass dieser leichter den Bestand indexieren und aktualisieren kann.

Das Modul stellt eine dynamisch generierte Google Sitemap für eine PostNuke-Seite zur Verfügung und unterstützt dabei einige der meisten populären Module. Weitere Plugins für bisher nicht unterstützte Module können leicht geschrieben werden. Zur Zeit werden News, Topics, Stats, Members List, Downloads, Web Links, pnForum, PageSetter, Photoshare, pnFlashGames, phpcomic, AmaZone, Books und pnZClassifieds unterstützt. Credits gehen an Jean-Michel Vedrine, der viele dieser Plugins geschrieben hat.

Dieses Modul benötigt PostNuke .762 oder höher. Es wurde nur mit .762 getestet und kann mit älteren Versionen aufgrund eines geänderten ShortURL-Filters Probleme machen.


 

Kommentare

  • Geschrieben am
  • 20. Mär 2006 - 12:40
Versionsnummer

Quote

Dieses Modul benötigt PostNuke .762 oder höher. Es wurde nur mit .762 getestet und kann mit älteren Versionen aufgrund eines geänderten ShortURL-Filters Probleme machen.

Uns Anwendern wird immer gepredigt, die neusten Updates auf die aktuellen PN-Versionen zu fahren... Die Argumente sind immer, der Updatevorgang wäre so einfach, wenig zeitaufwendig und würde die Sicherheit des Systems erhöhen.

Für Entwickler gilt das nicht? icon_wink

  • Geschrieben am
  • 20. Mär 2006 - 14:06

762 ist doch die aktuelle Version. Höher geht noch nicht (stable).

  • Geschrieben am
  • 24. Mär 2006 - 19:46
sorry

[nimmt die Tomaten von den Augen und guckt nochmal genau hin]

Oh Stimmt! Sah von hier hinten aus wie .726 --- da hab ich mich wohl vertan icon_wink Dazu gibt es einen coolen song von Helge Schneider ("Ich habe mich vertan").

Nur angemeldete Benutzer dürfen kommentieren. Registrierung oder Anmeldung.