Upgrade von 1.3.12 auf 1.4.6 klappt nicht  Unten

  • Ich versuche gerade den Upgrade einer Testinstallation von 1.3.12 auf 1.4.6

    Ich hatte eine aeltere 1.3.X version laufen, die ich wie in der Beschreibung gefordert, auf 1.3.12 gebrache habe. Dieser Upgrade ist problemlos gelaufen und die Site laeuft.

    Wenn ich jetzt auf 1.4.6 weitergehen moechte, bringt upgrade.php nur eine leere Seite und im CLI bekomme ich diese Meldung:


    Code

    $php app/console zikula:upgrade
       
                                                                                       
          [Symfony\Component\DependencyInjection\Exception\ParameterNotFoundException]  
          You have requested a non-existent parameter "core_installed_version".


    Es ist in der Upgradebeschreibung von einer Datei app/config/parameters.yml die Rede, die man vor dem upgrade in personal_parameters.yml umbenennen soll.

    Die Datei existiert nicht in meiner 1.3.12 Version.

    Hat jemand eine Idee?

    Kann ich z.B eine neue Installation machen, dann meine Module - News, Content, Download, Mediashare- installieren und per phpmysql die Daten ein die Tabellen bringen?



    Bearbeitet von wellenreiter am 12. Mai 2017 - 14:42.

    Viele Gruesse aus Essen



    Wellenreiter




    Es gibt keine Probleme, nur Aufgaben

  • Quote

    Es ist in der Upgradebeschreibung von einer Datei app/config/parameters.yml die Rede, die man vor dem upgrade in personal_parameters.yml umbenennen soll.

    Die existiert in 1.4.6 und muss in custom_parameters.yml umbenannt und mit den relevanten Daten versehen werden.
    Grundsätzlich ist es ratsam, erst den Core ohne Module upzugraden.
    Dann kannst Du sukzessive die Module upgraden.

    Mediashare wird ziemlich sicher nicht laufen, bei Downloads bin ich auch skeptisch. Content und News sollten funktionieren.

    PS: Du hast einen Zahlendreher im Titel. icon_wink

  • Quote

    Mediashare wird ziemlich sicher nicht laufen, bei Downloads bin ich auch skeptisch. Content und News sollten funktionieren.


    Mediashare, bzw. der Bedarf Video-Dateien in News- und Content-Artikeln anzuzeigen ist der eigentliche Grund, warum ich ueber den Upgrade nachdenke.
    Ich bekomme Mediashare unter 1.3.x nicht zum laufen. Das Modul laesst sich zwar installieren, aber ich bekomme Fehler, wenn ich versuche Media-Dateien hochzuladen.

    Wenn ich es ein anderes Modul gaebe, das Videos in Newartikeln anzeigen kann, wuerde ich mir den Upgrade sparen.
    Youtube ist leider keine Option...

    Ich werde die custom_parameters.yml mal erstellen und sehen, ob der Upgrade dann klappt.

    Viele Gruesse aus Essen



    Wellenreiter




    Es gibt keine Probleme, nur Aufgaben

  • 0 Benutzer

Diese Angaben basieren auf den Useraktivitäten der letzten 30 Minuten.